
Написать программу, которая задумывает число в диапазоне от -50 до 50 и предлагает пользователю
угадать число за 10 попыток (номер попытки выводится), программа сообщает, больше или меньше загаданное число путем вывода сообщения. После чего программа выводит на «Вам удалось!» или «Попробуйте еще раз.». (на Паскале)

Ответы на вопрос

Ответ:
Program zadumai;
Var
a, k, i: integer;
Begin
a:= random (101)-50;
for i := 1 to 10 do
begin
write ('Попробуйте угадать задуманное число. Попытка №', i, ': ');
readln (k);
if a=k then
begin
writeln ('Вам удалось!');
exit;
end
else
begin
end;
if a>k then writeln ('Задуманное число больше. Попробуйте еще раз.')
else writeln ('Задуманное число меньше. Попробуйте еще раз.');
end;
write (a,'-задуманное число. Попробйуйте еще раз!')
end.





Ответ:
program ugadai;
var a,b,k:integer;
begin
b:=random(101)-50;
writeln('Попробуйте угадать число от -50 до 50 за 10 попыток');
writeln;
k:=1;
repeat
write('Попытка ',k,'. Введи число: ');
readln(a);
if a>b then writeln('Загаданное число меньше!')
else if a<b then writeln('Загаданное число больше!')
else if a=b then
begin
writeln;
writeln('Вам удалось!');
k:=13;
end;
k:=k+1
until k>10;
if k=11 then
begin
writeln;
writeln('Попробуйте еще раз.')
end
end.
Объяснение:
Загадываем число (random)
Цикл с пост условием, k - счётчик попыток.
Условный оператор для корректировки угадывания.
Если все попытки исчерпаны, вывод предложения попробовать ещё раз.



Конечно, вот пример программы на Pascal, которая реализует описанное вами поведение:
pascalprogram GuessNumber; var secretNumber, guess, attempts: Integer; begin // Инициализация генератора случайных чисел Randomize; // Загадываем число secretNumber := Random(101) - 50; // Генерируем число от -50 до 50 attempts := 10; writeln('Угадайте число, которое загадала программа (от -50 до 50).'); while attempts > 0 do begin write('Попытка ', 11 - attempts, ': '); readln(guess); if guess = secretNumber then begin writeln('Вам удалось!'); break; end else if guess < secretNumber then writeln('Загаданное число больше.') else writeln('Загаданное число меньше.'); Dec(attempts); end; if attempts = 0 then writeln('Попробуйте еще раз.'); readln; end.
Просто скопируйте этот код в среду программирования для Pascal, и он будет выполнять описанные вами действия. Программа будет генерировать случайное число в указанном диапазоне и предоставлять пользователю 10 попыток для угадывания этого числа.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili