
Написать программу в Паскале: "Ввести число. Если оно четное,разделить его на 4, если нечетное
-умножить на 5"

Ответы на вопрос

Ответ:
program dadaya;
var a:integer;
b:real;
begin
write(' введите заданное число ');
read(a);
if a mod 2 = 0
then b:= a / 4
else b:= a * 5;
write(' Полученный ответ = ', b:5:2);
end.
Объяснение:



Конечно, вот пример программы на Паскале, который выполняет указанные действия:
pascalprogram NumberOperation; var number: integer; begin writeln('Введите число:'); readln(number); if number mod 2 = 0 then begin number := number div 4; writeln('Число четное. Результат деления на 4:', number); end else begin number := number * 5; writeln('Число нечетное. Результат умножения на 5:', number); end; readln; end.
В этой программе мы сначала запрашиваем у пользователя ввод числа. Затем мы используем оператор if
для проверки, является ли число четным (number mod 2 = 0
). Если число четное, мы выполняем деление на 4 и выводим результат. Если число нечетное, мы выполняем умножение на 5 и выводим результат.
Программа ожидает, что пользователь введет целое число и нажмет клавишу Enter
. Затем программа выведет результат операции и остановится, ожидая нажатия клавиши Enter
, чтобы закрыть окно программы.


Похожие вопросы







Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili