Вопрос задан 01.07.2023 в 06:21. Предмет Информатика. Спрашивает Кон Владислав.

Написать 4 лёгкие программы на C++ 1. Напишите программу для вычисления суммы нечетных

натуральных чисел с использованием оператора for. 2. Начав тренировки, спортсмен в первый день пробежал М км. Каждый день он увеличивал дневную норму на Р% нормы предыдущего дня. В какой день впервые спортсмен пробежит более K км? 3. Клиент оформил вклад на m тысяч рублей в банке под k% годовых. Через сколько лет сумма вклада превысит s тысяч рублей, если за это время клиент не будет брать деньги со счета. 4. Написать программу, вычисляющую сумму и среднее арифметическое последовательности положительных чисел, которые вводятся с клавиатуры.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Фролов Саша.

#include<iostream>

using namespace std;

int main()

"Шапка" для всех программ, я напишу функцию main. Что бы работало "шапку" надо каждый раз писать.

№1 (Задаче решается легче через формулу: 1 + 3 + 5 + … + ( 2 n − 1 ) = n ²)

{

unsigned int n, z; // z - начальная точка отрезка, n - конечная. (z, n > 0)

unsigned int S = 0; // S - сумма нечетных  

// cin >> n; - если надо использовать ввод через клавиатуру

z = 1; n = 11;

// вычисляет сумма натуральных нечетных чисел от z(1) до n(1). Если нужен другой отрезок смени значение z, n. В условии не сказан конкретный отрезок.

for(unsigned int i = z; i <= n; i += 2)

 S += i;

cout << S; // Если надо вывести значение на экран, опять же в условии сказано лишь вычислить сумму, про вывод не слова :(

return 0;

}

№2

{

double M, P, K;

cin >> M >> P >> K;

P = P / 100 + 1; // Что бы представить %, в виде числа.

int dayCounter = 0;

for(double i = M; i <= K; i *= P)

 dayCounter ++;

cout << dayCounter;

return 0;

}

№3 (Задача абсолютно такая же, как и 2-ая)

{

double m, k, s;

cin >> m >> k >> s;

k = k / 100 + 1; // Что бы представить %, в виде числа.

int yearsCounter = 0;

for(double i = m; i <= s; i *= k)

 yearsCounter ++;

cout << yearsCounter;

return 0;

}

№4(Если признаком окончанием последовательности является 0)

{

double s = 0,

averageS,

enteredNum;

int k = 0;

while(cin >> enteredNum && enteredNum)

 {

    if(enteredNum > 0) s += enteredNum;

    k ++;

 }

averageS = s / k;

cout << s << " " << averageS;

return 0;

}

0 0
Отвечает Миронов Алексей.

Ответ:

~~~~~~~~~~~~~

1)

#include <iostream> // Библиотека ввода - вывода

using namespace std; // Пространство имён

int main()  

{

   int amount = 0; // Сумма нечетных чисел

   int first, last; // Первое и конечное значения

   cin >> first >> last; // Вводим первое и конечное значения с клавиатуры

   for (int i = first; i <= last; i++) // Идём от первого до конечного значения включительно

   {

       if (i % 2 != 0) // Если значение переменной i делится на 2 без остатка

       {

           amount += i; // Суммируем этот элемент

       }

   }

   cout << amount; // Выводим ответ

}

~~~~~~~~~~~~~

2)

#include <iostream> // Библиотека ввода - вывода

using namespace std; // Пространство имён

int main()  

{

   double m, p, k; // Переменные по условию

   int day = 1; // Мы уже знаем, сколько он пробежал в 1 день => переменная, хранящая дни, равна единице

   cin >> m >> p >> k; // Вводим значение с клавиатуры

   p = p / 100 + 1; // Переводим процент в число

   for (double i = m; i <= k; i *= p) // Идём, пока m ≤ k

   {

       day++; // Прибавляем единицу  

   }

   cout << day; // Выводим ответ

}

~~~~~~~~~~~~~

3)

#include <iostream> // Библиотека ввода - вывода

using namespace std; // Пространство имён

int main()  

{

   double m, p, s; // Переменные по условию

   int year = 0; // Начинаем отсчёт с нулевого года

   cin >> m >> p >> s; // Вводим значение с клавиатуры

   p = p / 100 + 1; // Переводим процент в число

   for (double i = m; i <= s; i *= p) // Идём, пока m ≤ s

   {

       year++; // Прибавляем единицу  

   }

   cout << year; // Выводим ответ

}

~~~~~~~~~~~~~

4)

#include <iostream> // Библиотека ввода - вывода

using namespace std; // Пространство имён

int main()  

{

   double amount = 0; // Сумма чисел последовательности

   int quantity = 0; // Количество чисел последовательности

   int number; // Переменная, хранящая значения последовательности

   double arithmetic_mean; // Переменная, хранящая среднее арифметическое

   cin >> number; // Вводим значение с клавиатуры

   while (number != 0) // Пока значение переменной number ≠ 0

   {

       if (number > 0) // Если переменная number - положительное число

       {

           amount += number; // Суммируем

           quantity++; // Количество = + 1

       }

       cin >> number; // Вводим значение с клавиатуры

   }

   arithmetic_mean = amount / quantity;  // Вычисляем среднее арифметическое

   cout << "Сумма = " << amount << endl << "Среднее арифметическое = " << arithmetic_mean;  // Выводим ответ

}

~~~~~~~~~~~~~

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот четыре программы на C++, решающие описанные задачи:

Программа 1: Вычисление суммы нечетных натуральных чисел с использованием оператора for:

cpp
#include <iostream> int main() { int n; std::cout << "Введите число n: "; std::cin >> n; int sum = 0; for (int i = 1; i <= n; i += 2) { sum += i; } std::cout << "Сумма нечетных чисел до " << n << " равна: " << sum << std::endl; return 0; }

Программа 2: Вычисление дня, когда спортсмен пробежит более K км:

cpp
#include <iostream> int main() { double M, P, K; std::cout << "Введите начальную дистанцию M (км): "; std::cin >> M; std::cout << "Введите процент увеличения дневной нормы P: "; std::cin >> P; std::cout << "Введите цель дистанции K (км): "; std::cin >> K; int day = 1; double distance = M; while (distance < K) { distance *= (1 + P / 100); day++; } std::cout << "Спортсмен пробежит более " << K << " км на " << day << " день." << std::endl; return 0; }

Программа 3: Вычисление времени для превышения суммы вклада:

cpp
#include <iostream> int main() { double m, k, s; std::cout << "Введите сумму вклада m (тысячи рублей): "; std::cin >> m; std::cout << "Введите процент годовых k: "; std::cin >> k; std::cout << "Введите цель суммы s (тысячи рублей): "; std::cin >> s; int years = 0; while (m < s) { m *= (1 + k / 100); years++; } std::cout << "Сумма вклада превысит " << s << " тысяч рублей через " << years << " лет." << std::endl; return 0; }

Программа 4: Вычисление суммы и среднего арифметического последовательности положительных чисел:

cpp
#include <iostream> int main() { int count = 0; double sum = 0; double number; while (true) { std::cout << "Введите положительное число (или отрицательное для завершения): "; std::cin >> number; if (number < 0) { break; } sum += number; count++; } if (count > 0) { double average = sum / count; std::cout << "Сумма: " << sum << std::endl; std::cout << "Среднее арифметическое: " << average << std::endl; } else { std::cout << "Не было введено положительных чисел." << std::endl; } return 0; }

Просто скопируйте соответствующий код в файл с расширением .cpp и скомпилируйте его, чтобы запустить каждую из программ.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос