
Вопрос задан 01.07.2023 в 05:19.
Предмет Информатика.
Спрашивает Головченко Ваня.
НАПИШИТЕ ПРОГРАММУ ДЛЯ C++ ДЛЯ НОВИЧКА Пирожок в столовой стоит A рублей и B копеек. Определите,
сколько рублей и копеек нужно заплатить за N пирожков.Формат входных данныхПрограмма получает на вход три числа: A, B, N - целые, положительные, не превышают 10000.Формат выходных данныхПрограмма должна вывести два числа через пробел: стоимость покупки в рублях и копейках

Ответы на вопрос

Отвечает Петров Данил.
Объяснение:
python
a = int(input())
b = int(input())
n = int(input())
cost = n * (100 * a + b)
print(cost // 100, cost % 100)
прости, пишу только на python. Но мне кажется дальше разберёшься и перепишешь на c++



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на C++, которая решает задачу:
cpp#include <iostream>
int main() {
int A, B, N;
std::cin >> A >> B >> N;
int totalRubles = A * N + (B * N) / 100;
int totalKopeks = (B * N) % 100;
std::cout << totalRubles << " " << totalKopeks << std::endl;
return 0;
}
Вы можете скопировать этот код в среду разработки на C++, сохранить его в файл с расширением .cpp
и скомпилировать, чтобы выполнить программу. Программа сначала считывает значения A
, B
и N
(стоимость одного пирожка в рублях и копейках, количество пирожков), затем вычисляет общую стоимость покупки в рублях и копейках, и выводит результат.
Обратите внимание, что в этой программе предполагается, что пользователь вводит корректные значения, и не проведена проверка на ошибки ввода.


Похожие вопросы
Топ вопросов за вчера в категории Информатика

Информатика 565

Информатика 25

Информатика 22

Информатика 27

Информатика 34

Информатика 58

Информатика 63

Информатика 23
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili