
Помогите, пожалуйста, написать программу для С++ Дан массив из n элементов. Найти сумму
элементов, стоящих на нечетных местах и вывести их на экран. Затем вставить их в новый массив умножив на n, и удалить последний элемент.

Ответы на вопрос

#include <iostream>
#include <cstdlib>
#include <ctime>
#include <vector>
using namespace std;
int main() {
vector<int> arr;
int n;
cout << "n: ";
cin >> n;
srand(time(0));
long long sum = 0;
vector<long int> multi;
for(int i = 0; i<10; ++i) { // тут поменять чтобы изменить колво чисел
arr.push_back(rand());
if(i%2!=0) {
sum+=arr[arr.size()-1];
cout << arr[i] << " ";
multi.push_back(arr[arr.size()-1]*n);
}
}
cout << endl << "Multi: ";
for(int i = 0; i<multi.size(); ++i) {
cout << multi[i] << " ";
}
}



Конечно, вот пример программы на C++, которая решает вашу задачу:
cpp#include <iostream>
#include <vector>
int main() {
int n;
std::cout << "Введите размер массива: ";
std::cin >> n;
if (n <= 0) {
std::cout << "Размер массива должен быть положительным числом." << std::endl;
return 1;
}
std::vector<int> arr(n);
std::cout << "Введите элементы массива: ";
for (int i = 0; i < n; ++i) {
std::cin >> arr[i];
}
int sum = 0;
// Найти сумму элементов, стоящих на нечетных местах
for (int i = 0; i < n; i += 2) {
sum += arr[i];
}
std::cout << "Сумма элементов, стоящих на нечетных местах: " << sum << std::endl;
// Создать новый массив
std::vector<int> newArr(n - 1);
for (int i = 0; i < n - 1; ++i) {
newArr[i] = arr[i * 2] * n;
}
// Вывести новый массив
std::cout << "Новый массив после умножения на n и удаления последнего элемента: ";
for (int i = 0; i < n - 1; ++i) {
std::cout << newArr[i] << " ";
}
std::cout << std::endl;
return 0;
}
Программа сначала запрашивает размер массива (n) и элементы массива, а затем находит сумму элементов, стоящих на нечетных местах, создает новый массив, умножая элементы на n, и удаляет последний элемент нового массива.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili