Срочно пж! Нужно написать программу на c++ 15. Дан одномерный массив, состоящий из N вещественных
элементов. 15.1. Ввести массив с клавиатуры. 15.2. Найти минимальный положительный элемент. 15.3. Вычислить сумму четных элементов массива. 15.4. Вывести массив на экран в обратном порядке.Ответы на вопрос
#include <iostream>
#include <cstdlib>
#include <ctime>
#include <vector>
#include <algorithm>
using namespace std;
int main() {
vector<int> arr;
int size, min(9999999), sum(0);
cout << "N: ";
cin >> size;
for (int i = 0; i < size; ++i) {
int temp;
cout << "Element #" << i + 1 << ": ";
cin >> temp;
arr.push_back(temp);
if (temp >= 0 && temp < min) {
min = temp;
}
if ((i + 1) % 2 == 0) { // нумеруем элементы с 1
sum += temp;
}
}
cout << "Min: " << min << endl;
cout << "Sum: " << sum << endl;
for (int i = arr.size()-1; i>=0; --i) {
cout << arr[i] << " ";
}
}

Конечно, вот программа на C++, которая выполняет задачи, описанные в вашем запросе:
cpp#include <iostream>
#include <vector>
int main() {
int N;
std::cout << "Введите размер массива: ";
std::cin >> N;
if (N <= 0) {
std::cout << "Размер массива должен быть положительным числом." << std::endl;
return 1;
}
std::vector<double> arr(N);
// Ввод массива с клавиатуры
std::cout << "Введите элементы массива:" << std::endl;
for (int i = 0; i < N; i++) {
std::cin >> arr[i];
}
// Находим минимальный положительный элемент
double min_positive = -1.0;
for (int i = 0; i < N; i++) {
if (arr[i] > 0 && (min_positive == -1.0 || arr[i] < min_positive)) {
min_positive = arr[i];
}
}
if (min_positive == -1.0) {
std::cout << "В массиве нет положительных элементов." << std::endl;
} else {
std::cout << "Минимальный положительный элемент: " << min_positive << std::endl;
}
// Вычисляем сумму четных элементов массива
double even_sum = 0.0;
for (int i = 0; i < N; i++) {
if (static_cast<int>(arr[i]) % 2 == 0) {
even_sum += arr[i];
}
}
std::cout << "Сумма четных элементов массива: " << even_sum << std::endl;
// Выводим массив на экран в обратном порядке
std::cout << "Массив в обратном порядке:" << std::endl;
for (int i = N - 1; i >= 0; i--) {
std::cout << arr[i] << " ";
}
std::cout << std::endl;
return 0;
}
Эта программа сначала запрашивает размер массива, затем вводит элементы массива с клавиатуры. После этого она находит минимальный положительный элемент, вычисляет сумму четных элементов и выводит массив в обратном порядке.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
