Вопрос задан 19.06.2023 в 12:20. Предмет Информатика. Спрашивает Константинопольский Данил.

Сумма двух списков На вход программе подаются две строки текста, содержащие целые числа. Из данных

строк формируются списки чисел L и M. Напишите программу, которая создает третий список, элементами которого являются суммы соответствующих элементов списков L и M. Далее программа должна вывести каждый элемент полученного списка на одной строке через 1 пробел Питон ​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Харченко Валерия.

Ответ:

L = [s for s in input().split(',')] #ввод через запятую

M = [s for s in input().split(',')] #ввод через запятую

C = []

if len(L) > len(M):

   N = len(M)

else:

   N = len(L)

for i in range(N):

   C.append(int(L[i]) + int(M[i]))

   print(C[i], end=' ')

Объяснение:

0 0
Отвечает Казакова Елизавета.

Ответ:

for L, M in zip(input().split(), input().split()):

   print(int(L) + int(M), end=' ')

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Python код для суммирования двух списков

Вот пример программы на Python, которая создает третий список, элементами которого являются суммы соответствующих элементов списков L и M:

```python def sum_lists(L, M): result = [] for i in range(len(L)): result.append(L[i] + M[i]) return result

# Пример использования L = [1, 2, 3] M = [4, 5, 6] result = sum_lists(L, M) print(*result) ```

В этом примере функция `sum_lists` принимает два списка L и M в качестве аргументов и возвращает новый список, содержащий суммы соответствующих элементов. Затем мы передаем два списка `[1, 2, 3]` и `[4, 5, 6]` в функцию `sum_lists` и выводим результат на экран с помощью `print(*result)`.

Примечание: В этом примере предполагается, что списки L и M имеют одинаковую длину. Если списки имеют разную длину, код может вызвать ошибку.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос