 
Вопрос задан 30.06.2023 в 08:44.
Предмет Информатика.
Спрашивает Чередник Иван.
Написать программу на языке паскаль. Ввести с клавиатуры число N, 1>=N<=3. В зависимости от
введенного числа вычислить и выдать на экран значения функции, 1) у = sin (п) 2) y = cos (п) 3) y = tg (п) Если введено другое число - выдать сообщение об ошибке. 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Яковлев Егор.
                
    Ответ:
Объяснение:
Var
N:integer;
a,b,c:real;
Begin
Writeln( ' Введите число N ');
Readln(N);
If ((N>=1)AND(N<=1)) then
begin
a:= sin(N);
b:=cos(N);
c:= a / b;
Writeln( ' sin(N) = ' , a);
Writeln( ' cos(N) = ' , b);
Writeln ( ' tg(N) = , c) ;
end;
If ((N<1)AND(N>3)) then
Writeln( ' Ошибка: Данные введены неверно' );
end.
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Вот пример программы на языке Pascal, которая выполняет задачу, описанную в вашем запросе:
pascalprogram CalculateFunction; var N: Integer; y: Real; begin writeln('Введите число N (1, 2 или 3): '); readln(N); case N of 1: begin y := sin(pi); writeln('y = sin(pi) = ', y:0:4); end; 2: begin y := cos(pi); writeln('y = cos(pi) = ', y:0:4); end; 3: begin y := tan(pi); writeln('y = tan(pi) = ', y:0:4); end; else writeln('Ошибка: введите число 1, 2 или 3.'); end; readln; end.
Эта программа сначала запрашивает ввод числа N с клавиатуры, затем использует оператор case для выполнения соответствующих вычислений в зависимости от значения N. Если введено число, отличное от 1, 2 или 3, программа выдаст сообщение об ошибке.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			