 
Вопрос задан 29.06.2023 в 04:29.
Предмет Информатика.
Спрашивает Марьямова Полина.
Написать программу создающую массив из N целых элементов со случайными значениями в диапазоне [-50;
50]. Подсчитать среднее арифметическое элементов массива, кратных трем. 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Кузнецова Марина.
                
    Ответ:
const n=20;
var a:array[1..n] of integer;
i,b,c:integer; k:real;
Begin
for i:=1 to n do read(a[i]);
b:=0;
c:=0;
for i:=1 to n do begin
if (a[i] mod 3 = 0) then begin
b:=b+a[i];
c:=c+1;
end;
end;
k:=b/c;
writeln(k);
end.
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Вы можете написать такую программу на языке Python, используя библиотеку random для генерации случайных чисел и цикл для обхода массива и подсчета среднего арифметического кратных трём элементов. Вот пример такой программы:
pythonimport random
# Запросите у пользователя количество элементов в массиве N
N = int(input("Введите количество элементов в массиве: "))
# Инициализируйте массив случайными значениями в диапазоне [-50; 50]
arr = [random.randint(-50, 50) for _ in range(N)]
# Инициализируйте переменные для подсчета суммы и количества элементов, кратных 3
sum_of_multiples_of_3 = 0
count_of_multiples_of_3 = 0
# Пройдитесь по элементам массива и подсчитайте сумму и количество элементов, кратных 3
for num in arr:
    if num % 3 == 0:
        sum_of_multiples_of_3 += num
        count_of_multiples_of_3 += 1
# Проверьте, чтобы избежать деления на 0
if count_of_multiples_of_3 > 0:
    # Вычислите среднее арифметическое элементов, кратных 3
    average_of_multiples_of_3 = sum_of_multiples_of_3 / count_of_multiples_of_3
    print(f"Массив: {arr}")
    print(f"Среднее арифметическое элементов, кратных 3: {average_of_multiples_of_3}")
else:
    print("В массиве нет элементов, кратных 3.")
Эта программа сначала создает массив случайных целых чисел, затем проходит по этому массиву, подсчитывает сумму и количество элементов, кратных 3, и наконец, вычисляет среднее арифметическое элементов, кратных 3.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			