РЕШИТЕ ПОЖАЛУЙСТА В ПАСКАЛЕ ДАЮ 50 БАЛЛОВ!!!!!! 2. Найти сумму положительных элементов массива,
содержащего 7 элементов. Элементы вводятся с клавиатуры. 3. Найти наименьший элемент одномерного массива, состоящего из 12 элементов и сформированного случайными числами, не превосходящими 10Ответы на вопрос
Ответ:
Задача номер два:
program CountPositiveElements;
var
elements: array[Integer] of Integer;
sum: Integer = 0;
i: Integer;
begin
writeln ('Введите семь элементов.');
for i:= 0 to 6 do
begin
write (i+1, ':');
ReadLn(elements[i]);
end;
for i:=0 to 6 do
begin
if elements[i] > 0 then
sum := sum + elements[i];
end;
writeln('Сумма положительных элементов массива: ', sum)
end.
Задача номер три:
program MinElementFinder;
var
minElement: Integer;
input: array[Integer] of Integer;
i: Integer;
begin
Randomize;
for i:= 0 to 11 do
input[i] := random(10);
minElement := input[11];
write('Случайные элементы массива:');
for i:= 0 to 10 do
begin
write(input[i],',');
if minElement > input[i] then
minElement := input[i];
end;
writeln(input[11]);
writeln('Из них наименьший элемент:', minElement)
end.
Конечно, я помогу вам написать программу на языке Pascal для решения задачи. В первой задаче мы будем вводить элементы массива с клавиатуры и суммировать положительные элементы. Во второй задаче создадим одномерный массив из 12 случайных чисел и найдем наименьший элемент.
pascalprogram ArraySumAndMin; const ARRAY_SIZE = 7; RANDOM_MAX = 10; ARRAY_SIZE_RANDOM = 12; var arraySum, minValue: Integer; i, randomNumber: Integer; userInput: Integer; randomArray: array[1..ARRAY_SIZE_RANDOM] of Integer; begin // Инициализируем переменные arraySum := 0; minValue := RANDOM_MAX; // Изначально устанавливаем minValue в максимальное возможное значение // Задача 1: Найти сумму положительных элементов массива, введенного с клавиатуры writeln('Введите ', ARRAY_SIZE, ' элементов массива:'); for i := 1 to ARRAY_SIZE do begin write('Элемент ', i, ': '); readln(userInput); if userInput > 0 then arraySum := arraySum + userInput; end; writeln('Сумма положительных элементов: ', arraySum); // Задача 2: Найти наименьший элемент одномерного массива случайных чисел writeln('Наименьший элемент одномерного массива из случайных чисел:'); // Заполняем массив случайными числами и находим минимальное значение for i := 1 to ARRAY_SIZE_RANDOM do begin randomNumber := Random(RANDOM_MAX) + 1; // Генерируем случайное число от 1 до RANDOM_MAX randomArray[i] := randomNumber; if randomNumber < minValue then minValue := randomNumber; end; // Выводим элементы массива for i := 1 to ARRAY_SIZE_RANDOM do write(randomArray[i], ' '); writeln; writeln('Наименьший элемент: ', minValue); end.
Этот код решает задачи 1 и 2 согласно вашему запросу. Пожалуйста, проверьте его в вашей среде разработки Pascal.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
