
СРОЧНО, ПРОШУ Решить задачу: написать программу нахождения элемента массива равного 7. Вывести на
экран номер этого элемента. Если такого элемента не встретится, то вывести сообщение "нет" Массив заполняется случайными числами от 1 до 50. Использовать цикл с постусловием(repeat...until).

Ответы на вопрос

Проверку можно устроить, например, так. Пусть сначала i = 0, и в цикле увеличиваем i, пока не уйдем за границы массива или не встретим элемент, равный 7. После выхода из цикла проверяем, по какой причине был выход из цикла, и в зависимости от этого выводим либо номер элемента, либо сообщение об отсутствии семерок. При этом будет выведен только номер первой семерки, если их в массиве несколько.
Вывод массива можете дописать при необходимости самостоятельно, видимо, считается, что вы это умеете делать :)
Код (Pascal):
const
n = 20;
var
a: array[1..n] of integer;
i: integer;
begin
randomize;
for i := 1 to n do
a[i] := random(50) + 1;
i := 0;
repeat
i := i + 1;
until (i > n) or (a[i] = 7);
if i > n then
write('нет')
else
write(i)
end.



Конечно, вот программа на языке программирования Pascal, которая решает вашу задачу с использованием цикла с постусловием repeat...until
:
pascalprogram FindElement; var arr: array[1..100] of Integer; // Массив целых чисел i, n: Integer; // Переменные для цикла и размера массива found: Boolean; // Переменная для отслеживания нахождения элемента begin Randomize; // Инициализация генератора случайных чисел // Заполняем массив случайными числами от 1 до 50 n := 100; // Размер массива (можно изменить по желанию) for i := 1 to n do arr[i] := Random(50) + 1; // Генерируем случайное число от 1 до 50 found := False; // Исходно элемент не найден // Ищем элемент равный 7 i := 1; repeat if arr[i] = 7 then begin writeln('Элемент 7 найден в позиции ', i); found := True; end; i := i + 1; until (i > n); // Если элемент не был найден if not found then writeln('Нет элемента 7 в массиве'); end.
Эта программа создает массив из случайных чисел от 1 до 50 и затем использует цикл с постусловием, чтобы найти элемент равный 7. Если элемент 7 найден, программа выводит его позицию в массиве. Если элемент не найден, она выводит сообщение "Нет элемента 7 в массиве".


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili