Напишите программу в C++: Найти сумму и количество целых чисел больших 20, меньших 200 и кратных
3. Вывести числа, удовлетворяющие условию, их количество, найденную сумму, среднее арифметическое. Вывести числа, заканчивающиеся на 0.Ответы на вопрос
#include <iostream>
#include <vector>
using namespace std;
int main()
{
float summa, count = 0;
vector<int> result, zero;
for (int i = 21; i < 200; i++)
{
if (i % 3 == 0)
{
result.push_back(i);
count++;
summa += i;
if (i % 10 == 0)
{
zero.push_back(i);
}
}
}
cout << R"(Числа которые заканчиваютса нулем )" << endl;
for (int i = 0; i < zero.size(); i++)
{
cout << zero[i] << ' ';
}
cout << endl;
cout << R"(Числа которые кратные 3)" << endl;
for (int i = 0; i < result.size(); i++)
{
cout << result[i] << ' ';
}
cout << endl;
cout << R"(Количество таких чисел = )" << count << endl;
Дальше немного сами подумайте если я это написал и вы это не поняли. Советую учить С++. Потому что вы не будете понимать что вы делаете.
Вот пример программы на C++, которая находит сумму и количество целых чисел больше 20, меньше 200 и кратных 3, а также выводит числа, удовлетворяющие этому условию, их количество, найденную сумму и среднее арифметическое. Программа также выводит числа, заканчивающиеся на 0:
cpp#include <iostream>
int main() {
int count = 0; // Количество чисел, удовлетворяющих условию
int sum = 0; // Сумма чисел, удовлетворяющих условию
int endingWithZero = 0; // Количество чисел, заканчивающихся на 0
for (int i = 21; i < 200; i++) {
if (i % 3 == 0) {
count++;
sum += i;
std::cout << i << " ";
if (i % 10 == 0) {
endingWithZero++;
}
}
}
// Вывод результатов
std::cout << "\n\nЧисла, удовлетворяющие условию: " << count << " чисел\n";
std::cout << "Сумма: " << sum << "\n";
if (count > 0) {
double average = static_cast<double>(sum) / count;
std::cout << "Среднее арифметическое: " << average << "\n";
} else {
std::cout << "Среднее арифметическое нельзя вычислить, так как нет чисел удовлетворяющих условию.\n";
}
std::cout << "Числа, заканчивающиеся на 0: " << endingWithZero << " чисел\n";
return 0;
}
Программа начинает с числа 21, так как 20 не удовлетворяет условию "больше 20", и продолжает проверять числа до 199, так как 200 не удовлетворяет условию "меньше 200". Если число кратно 3 и удовлетворяет другим условиям, оно выводится, и его сумма и количество увеличиваются соответственно. Если число заканчивается на 0, увеличивается счетчик таких чисел. Результаты выводятся на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
