Вопрос задан 28.06.2023 в 19:42.
Предмет Информатика.
Спрашивает Требенок Алина.
Pascal, написать программу, находящую площадь и периметр треугольника.
Ответы на вопрос
Отвечает Павлов Данил.
Ответ:
var a,b,c,p,s:real;
begin
readln(a,b,c);
p:=a+b+c;
s:=sqrt(p/2*(p/2-a)*(p/2-b)*(p/2-c));
write('Периметр равен: ',p,' Площадь равна: ',s);
end.
Объяснение:

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Pascal, которая находит площадь и периметр треугольника, если известны его стороны:
pascalprogram CalculateTriangleAreaPerimeter; var Side1, Side2, Side3, Perimeter, Area, SemiPerimeter: real; begin writeln('Введите длину первой стороны треугольника: '); readln(Side1); writeln('Введите длину второй стороны треугольника: '); readln(Side2); writeln('Введите длину третьей стороны треугольника: '); readln(Side3); // Рассчитываем периметр треугольника Perimeter := Side1 + Side2 + Side3; // Рассчитываем полупериметр (для вычисления площади по формуле Герона) SemiPerimeter := Perimeter / 2; // Рассчитываем площадь треугольника по формуле Герона Area := sqrt(SemiPerimeter * (SemiPerimeter - Side1) * (SemiPerimeter - Side2) * (SemiPerimeter - Side3)); writeln('Периметр треугольника: ', Perimeter:0:2); writeln('Площадь треугольника: ', Area:0:2); end.
Просто введите длины трех сторон треугольника, и программа рассчитает его периметр и площадь.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
