Вопрос задан 28.06.2023 в 11:45. Предмет Информатика. Спрашивает Нурланулы Абдулл.

составьте программу которая среди n введённых пользователем чисел определяет, у скольких из них в

разряде десятков стоит 5? N вводится с клавиатуры в начале программы.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Пестов Алексей.

Вот

a = int(input())

lis = [i for i in input().split()]

count = 0

for i in lis:

   if int(i) > 9 and i[1] == '5':

       count+=1

print(count)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи вы можете использовать следующую программу на Python:

python
# Получаем количество чисел n от пользователя n = int(input("Введите количество чисел: ")) # Инициализируем счетчик чисел с 5 в разряде десятков count = 0 # Запрашиваем n чисел от пользователя и проверяем разряд десятков for i in range(n): num = int(input(f"Введите число #{i + 1}: ")) # Проверяем разряд десятков tens_digit = (num // 10) % 10 if tens_digit == 5: count += 1 # Выводим результат print(f"Среди введенных чисел {count} чисел имеют 5 в разряде десятков.")

Эта программа сначала запрашивает количество чисел n, которые пользователь хочет ввести. Затем она запрашивает сами числа и проверяет разряд десятков каждого числа. Если разряд десятков равен 5, программа увеличивает счетчик count. По завершении ввода чисел, программа выводит количество чисел, у которых 5 в разряде десятков.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос