Вопрос задан 28.06.2023 в 11:21. Предмет Информатика. Спрашивает Лавреженкова Светлана.

Напишите программу, которая считывает 8 чисел и выводит произведение чисел отличных от нуля и пяти.

Написать нужно на языке Питон и лучше чтобы все пробелы учитывались
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Антоненко Алина.

Ответ:

p=1

for i in range(8):

   x=int(input())

   if x!=0 and x!=5:

       p=p*x

print(p)

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот программа на Python, которая считывает 8 чисел, учитывает только числа, отличные от нуля и пяти, и выводит их произведение:

python
product = 1 # Инициализируем произведение единицей # Считываем 8 чисел for i in range(8): num = float(input("Введите число: ")) # Считываем число с клавиатуры # Проверяем, что число отличается от нуля и пяти if num != 0 and num != 5: product *= num # Умножаем на число, если оно подходит print("Произведение чисел, отличных от нуля и пяти:", product)

Вы можете скопировать этот код в среду программирования Python и выполнить его, чтобы увидеть результат. Программа будет считывать 8 чисел и выводить произведение чисел, которые отличаются от нуля и пяти.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос