
Помогите пожалуйста написать программу на PascalABC.NET Нужно подсчитать количество студентов
младше 16 лет, и вывести все данные о них

Ответы на вопрос

Ответ:
var
nm,snm:array of string;
age:array of integer;
k,s:integer;
begin
write('Введите общее кол-во студентов - '); readln(k);
setLength(nm,k); setLength(snm,k); setLength(age,k);
for var i1:=0 to k-1 do begin
writeln('[Студент ',i1+1,']');
write('Имя - '); readln(nm[i1]);
write('Фамилия - '); readln(snm[i1]);
write('Возраст - '); readln(age[i1]);
end;
for var i2:=0 to k-1 do
if age[i2]<16 then s:=s+1;
writeln; writeln('Кол-во студентов которым меньше 16 лет = ',s,' человек:');
for var i2:=0 to k-1 do begin
if age[i2]<16 then writeln(nm[i2],' ',snm[i2],' ',age[i2],' лет');
end;
end.



Конечно, вот пример программы на PascalABC.NET, которая позволит вам подсчитать количество студентов младше 16 лет и вывести данные о них:
pascalprogram StudentInfo; const MaxStudents = 100; // Максимальное количество студентов type Student = record Name: string; Age: integer; end; var Students: array[1..MaxStudents] of Student; Count, i: integer; begin // Ввод данных о студентах write('Введите количество студентов: '); readln(Count); // Ввод данных о каждом студенте for i := 1 to Count do begin writeln('Студент ', i, ':'); write('Имя: '); readln(Students[i].Name); write('Возраст: '); readln(Students[i].Age); end; // Вывод информации о студентах младше 16 лет writeln('Студенты младше 16 лет:'); for i := 1 to Count do begin if Students[i].Age < 16 then begin writeln('Имя: ', Students[i].Name); writeln('Возраст: ', Students[i].Age); end; end; readln; end.
Эта программа сначала запрашивает количество студентов, а затем запрашивает информацию о каждом студенте, включая имя и возраст. Затем программа выводит информацию о студентах младше 16 лет. Вы можете изменить MaxStudents
для увеличения максимального количества студентов, которые вы хотите ввести.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili