Вопрос задан 27.06.2023 в 16:27.
Предмет Информатика.
Спрашивает Мишин Михаил.
СРОЧНО!ДАЮ 50 БАЛЛОВ! ЯЗЫК ПАСКАЛЬДЕЛЁЖ ГРУШN школьников делят К груш поровну, неделяющийся
остаток остается в корзинке. Напишите программу, которая определяет, сколько груш останется в корзине? Формат входных данных: Программа считывает со стандартного потока ввода (stdin) или из файла input.tхt два натуральных числа К и N. Оба числа не превосходят 10000. Формат выходных данных: Программа должна вывести на стандартный потока вывода (stdout) или в файл оutрut.tхt одно число-ответ на вопрос в условии задачи.Ответы на вопрос
Отвечает Зайцева Ангелина.
Ответ:
program z1;
var k,n:integer;
begin
read(k,n);
write(k mod n)
end.
Объяснение:
Вводим числа
Выводим остаток от целочисленного деления
Отвечает Шамсиева Амелия.
Объяснение:
............................

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот простая программа на языке Pascal, которая решает данную задачу:
pascalprogram RemainderOfPears; var K, N, Remainder: Integer; begin // Ввод данных readln(K, N); // Вычисление остатка груш Remainder := N mod K; // Вывод результата writeln(Remainder); end.
Сохраните этот код в файле с расширением .pas, например, "pears.pas". Затем скомпилируйте и запустите программу с помощью компилятора Pascal, такого как Free Pascal.
Программа сначала считывает значения K и N, а затем использует оператор модуля (%) для вычисления остатка от деления N на K. Результат сохраняется в переменной Remainder и выводится на экран.
После компиляции и запуска программы, вы сможете ввести значения K и N, и программа выведет остаток груш в корзине.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
