Вопрос задан 27.06.2023 в 12:50. Предмет Информатика. Спрашивает Сокот Богдан.

ПРОГРАММИРОВАНИЕ PascalABC Вводится цифра месяца (от 1 до 12). В зависимости от цифры вывести

название месяца. Например, 1 = январь, 5 = май.​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Усенов Азиз.

var

 a: integer;

begin

 writeln('Введите число от 1 до 12:');

 readln(a);

 case a of

   1: writeln('Январь');

   2: writeln('Февраль');

   3: writeln('Март');

   4: writeln('Апрель');

   5: writeln('Май');

   6: writeln('Июнь');

   7: writeln('Июль');

   8: writeln('Август');

   9: writeln('Сентябрь');

   10: writeln('Октябрь');

   11: writeln('Ноябрь');

   12: writeln('Декабрь');

 end;

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вы можете написать программу на PascalABC, которая выполняет данную задачу. Вот пример программы:

pascal
program MonthName; var monthNumber: integer; begin write('Введите цифру месяца (от 1 до 12): '); readln(monthNumber); case monthNumber of 1: writeln('Январь'); 2: writeln('Февраль'); 3: writeln('Март'); 4: writeln('Апрель'); 5: writeln('Май'); 6: writeln('Июнь'); 7: writeln('Июль'); 8: writeln('Август'); 9: writeln('Сентябрь'); 10: writeln('Октябрь'); 11: writeln('Ноябрь'); 12: writeln('Декабрь'); else writeln('Неверный номер месяца'); end; readln; // Чтобы окно консоли не закрылось сразу end.

Эта программа сначала запрашивает у пользователя цифру месяца, затем использует оператор case для определения соответствующего названия месяца и выводит его на экран. Если введенное число не соответствует ни одному месяцу, программа выведет сообщение "Неверный номер месяца".

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос