
Вопрос задан 26.06.2023 в 23:34.
Предмет Информатика.
Спрашивает Лутков Никита.
напишите программу , которая проверяет,сколько раз введенное с клавиатуры число встречается в
массиве. предусмотрите сообщение , если такого числа в массиве нет. ( c++)

Ответы на вопрос

Отвечает Генних Никита.
Ответ:
#include <iostream>
using namespace std;
int main(int argc, char *argv[]) {
int arr[] = {1, 2, 3, 4, 5};
int x;
cout << "Введите число: ";
cin>>x;
int ina = 0;
for (int i = 0; i < (sizeof(arr)/sizeof(arr[0])); i++){
if (x == arr[i]){
ina++;
}
}
if (ina > 0) cout << "Число " << x << " встретилось в массиве " << ina << " раз(а)" << endl;
else cout << "Число " << x << " не найдено." << endl;
return 0;
}



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на C++, которая проверяет, сколько раз введенное с клавиатуры число встречается в массиве:
cpp#include <iostream>
int main() {
const int arraySize = 10; // Размер массива
int arr[arraySize] = {1, 2, 3, 4, 5, 2, 3, 2, 1, 2}; // Пример массива
int targetNumber; // Число, которое будем искать
int count = 0; // Счетчик вхождений числа в массив
// Запрос числа с клавиатуры
std::cout << "Введите число для поиска: ";
std::cin >> targetNumber;
// Проходим по массиву и считаем вхождения числа
for (int i = 0; i < arraySize; ++i) {
if (arr[i] == targetNumber) {
count++;
}
}
// Вывод результата
if (count > 0) {
std::cout << "Число " << targetNumber << " встречается в массиве " << count << " раз(а)." << std::endl;
} else {
std::cout << "Число " << targetNumber << " не найдено в массиве." << std::endl;
}
return 0;
}
В этой программе мы сначала объявляем массив arr
и заполняем его значениями. Затем мы запрашиваем число с клавиатуры и проходим по массиву, считая количество вхождений числа. Наконец, выводим результат на экран.


Похожие вопросы
Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili