Вопрос задан 26.06.2023 в 19:55. Предмет Информатика. Спрашивает Ребцовская Карина.

Составить программу C ПОМОЩЬЮ ФУНКЦИИ(ПАСКАЛЬ), вычисляющую и выводящую 10 первых членов

последовательности Фибоначчи
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Сидоренко Кристина.

Ответ:

function FibNum(a:longint):longint;

begin

   if a <= 2 then FibNum:=1

   else FibNum:=FibNum(a-1)+FibNum(a-2)

end;

var

i:integer;

begin

   for i:=1 to 10 do write(FibNum(i), ' ')

end.

Вывод программы:

1 1 2 3 5 8 13 21 34 55

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на языке Паскаль для вычисления и вывода первых 10 членов последовательности Фибоначчи может выглядеть следующим образом:

pascal
program FibonacciSequence; var i, n: integer; fib1, fib2, nextFib: integer; procedure PrintFibonacci(fib: integer); begin writeln(fib); end; begin fib1 := 0; fib2 := 1; writeln('Первые 10 членов последовательности Фибоначчи:'); PrintFibonacci(fib1); PrintFibonacci(fib2); for i := 3 to 10 do begin nextFib := fib1 + fib2; PrintFibonacci(nextFib); fib1 := fib2; fib2 := nextFib; end; end.

Эта программа начинает с двух начальных членов последовательности (0 и 1) и затем с помощью цикла for вычисляет и выводит следующие 8 членов последовательности.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос