Помогите! Надо написать программу паскаль,которая а)Просит ввести количество людей,затем просит
ввести их массу и выводит на экран их общюю массу б)В этой же программе надо добавить их среднюю массу. в) В этой же программе надо чтоб программа выводила на экран информацию,могут ли люди ехать в лифте чья грузоподъёмность 300 кг 31 балл даю.Ответы на вопрос
Ответ:
var n, k, i:integer;
m:real;
begin
readln(n);
for i:=1 to n do
begin
readln(k);
m := m + k;
end;
writeln('Общая масса: ', m);
writeln('Средняя масса: ', m/n);
if (m < 300) then
begin
writeln('Люди могут ехать!');
end
else
writeln('Ехать нельзя!');
end.
Объяснение:
б)В этой же программе надо добавить их среднюю массу.
Не совсем понял куда добавить, поэтому вывел.
Конечно, вот программа на языке Pascal, выполняющая указанные вами задачи:
pascalprogram MassCalculator; var n, i: integer; mass, totalMass, averageMass: real; begin totalMass := 0; write('Введите количество людей: '); readln(n); for i := 1 to n do begin write('Введите массу ', i, '-го человека (кг): '); readln(mass); totalMass := totalMass + mass; end; averageMass := totalMass / n; writeln('Общая масса всех людей: ', totalMass:0:2, ' кг'); writeln('Средняя масса людей: ', averageMass:0:2, ' кг'); if totalMass <= 300 then writeln('Люди могут ехать в лифте, его грузоподъемность составляет 300 кг.') else writeln('Люди не могут ехать в лифте, его грузоподъемность составляет 300 кг.'); end.
Эта программа сначала запрашивает количество людей, затем вводит их массу и выводит общую массу и среднюю массу. После этого она проверяет, могут ли люди ехать в лифте с грузоподъемностью 300 кг и выводит соответствующее сообщение.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
