Вопрос задан 26.06.2023 в 08:11. Предмет Информатика. Спрашивает Савосина Дарья.

PYTHON С клавиатуры вводится число N и цифра K. Вывести N раз словесное описание цифры

K:0−zero,1−one,2−two,3−three,4−four,5−five,6−six,7−seven,8−eight,9−nine. Формат входных данных Вводятся два целых неотрицательных числа N и K(1≤N≤231−1;0≤K≤9). Формат выходных данных Вывести в строчку N раз словесное описание цифры K. входные данные выходные данные 5 8 eight eight eight eight eight
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Сағынғанова Ханшайым.

Код в прикрепленном скриншоте:


0 0
Отвечает Палько Катя.

Ответ:

Объяснение:

a, b = map(int, input().split(' '))  

if b == 0:

       for g in range(a):

           print("zero")

if b == 1:

       for g in range(a):

           print("one")

if b == 2:

       for g in range(a):

           print("two")

if b == 3:

       for g in range(a):

           print("three ")

if b == 4:

       for g in range(a):

           print("four")

if b == 5:

       for g in range(a):

           print("five")

if b == 6:

       for g in range(a):

           print("six")

if b == 7:

       for g in range(a):

           print("seven")

if b == 8:

       for g in range(a):

           print("eight")

if b == 9:

       for g in range(a):

           print("nine")

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вы можете решить эту задачу на Python, используя цикл for для повторения словесного описания цифры K N раз. Вот пример решения:

python
# Ввод числа N и цифры K N = int(input()) K = int(input()) # Описания цифр descriptions = ["zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"] # Проверка на правильность ввода if 1 <= N <= 2**31-1 and 0 <= K <= 9: # Вывод словесного описания цифры K N раз for i in range(N): if i == N - 1: print(descriptions[K], end=" ") else: print(descriptions[K], end=" ") else: print("Пожалуйста, введите корректные значения для N и K.")

Этот код сначала считывает числа N и K с клавиатуры. Затем он проверяет, что введенные значения соответствуют условиям задачи, и выводит N раз словесное описание цифры K, разделяя их пробелами.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос