Нужно было написать программу, которая находит наибольшее из трех чисел a, b и c. Начинающий
программист написал фрагмент программы так: if a > b then M := a else M := b; if c > b then M := c else M := b; При каких наборах значений a, b, c эта программа работает неверно? Выберите все подходящие варианты. a = 1; b = 4; c = 7 a = 1; b = 7; c = 4 a = 7; b = 4; c = 1 a = 4; b = 7; c = 1 a = 7; b = 1; c = 4 a = 4; b = 1; c = 7 ОТВЕТ ДАЙТЕ ПРАВИЛЬНЫЙ НЕ ОТ БАЛДЫОтветы на вопрос
Ответ:
a = 1; b = 4; c = 7
a = 1; b = 7; c = 4
a = 4; b = 7; c = 1
a = 4; b = 1; c = 7
Объяснение:
Вот код программы на C++:
#include <iostream>
using namespace std;
void main()
{
setlocale (LC_ALL, "RUS");
int a, b, c, M;
cout << "Введите число а: ";
cin >> a;
cout << "Введите число b: ";
cin >> b;
cout << "Введите число c: ";
cin >> c;
if (a > b)
{
M = a;
}
else
{
M = b;
}
if (c > b)
{
M = c;
}
else
{
M = b;
}
cout << "Наибольшее число: " << M << endl;
}
______________________________________________
Можешь сам(а) на онлайн-компиляторе проверить выражения, если не уверен(а).
Давайте разберем каждый из наборов значений a, b и c и определим, когда программа работает неверно:
a = 1; b = 4; c = 7
- Первое условие: 1 > 4 - ложь, поэтому M = 4
- Второе условие: 7 > 4 - истина, поэтому M = 7
- Программа работает неверно.
a = 1; b = 7; c = 4
- Первое условие: 1 > 7 - ложь, поэтому M = 7
- Второе условие: 4 > 7 - ложь, поэтому M остается равным 7
- Программа работает верно.
a = 7; b = 4; c = 1
- Первое условие: 7 > 4 - истина, поэтому M = 7
- Второе условие: 1 > 4 - ложь, поэтому M остается равным 7
- Программа работает верно.
a = 4; b = 7; c = 1
- Первое условие: 4 > 7 - ложь, поэтому M = 7
- Второе условие: 1 > 7 - ложь, поэтому M остается равным 7
- Программа работает верно.
a = 7; b = 1; c = 4
- Первое условие: 7 > 1 - истина, поэтому M = 7
- Второе условие: 4 > 1 - истина, поэтому M = 4
- Программа работает неверно.
a = 4; b = 1; c = 7
- Первое условие: 4 > 1 - истина, поэтому M = 4
- Второе условие: 7 > 1 - истина, поэтому M = 7
- Программа работает неверно.
Итак, программа работает неверно в случаях 1, 5 и 6.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
