
в массиве A(N;N) где (N-четное число) определить сумму элементов, расположенных в четных и нечетных
строках. вывести массив и обе суммы

Ответы на вопрос

Ответ:
program z1;
const n=4;
var a : array [1..n,1..n] of integer;
i,j,s1,s2:integer;
begin
for i:=1 to n do
begin
for j:=1 to n do
begin
a[i,j]:=random(90)+10;
write(a[i,j]:4);
if i mod 2 <> 0 then s1:=s1+a[i,j]
else s2:=s2+a[i,j]
end;
writeln
end;
writeln(s1,' ',s2);
end.



Для решения этой задачи вам потребуется написать программу, которая создаст массив размером N x N, заполнит его случайными числами и затем найдет суммы элементов в четных и нечетных строках. Вот пример программы на языке Python:
pythonimport numpy as np
# Задайте четное значение N
N = 6
# Создайте массив размером N x N и заполните его случайными числами
A = np.random.randint(1, 10, size=(N, N))
# Выведите массив A
print("Массив A:")
print(A)
# Найдите сумму элементов в четных и нечетных строках
sum_even_rows = np.sum(A[::2, :]) # Сумма элементов в четных строках
sum_odd_rows = np.sum(A[1::2, :]) # Сумма элементов в нечетных строках
# Выведите суммы на экран
print("Сумма элементов в четных строках:", sum_even_rows)
print("Сумма элементов в нечетных строках:", sum_odd_rows)
В этом примере программа создает массив A размером N x N и заполняет его случайными числами. Затем она вычисляет сумму элементов в четных и нечетных строках массива и выводит эти суммы на экран. Не забудьте задать значение N как четное число в начале программы.


Похожие вопросы


Топ вопросов за вчера в категории Информатика








Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili