Вопрос задан 25.06.2023 в 12:14. Предмет Информатика. Спрашивает Беляев Сергей.

PYTHON! Определите номер самого большого из N чисел.Если есть несколько чисел максимального

размера - выведите номер последнего из них.Формат входных данныхС клавиатуры вводится 0 < N ≤ 1000Далее N целых положительных чисел ≤ 10000. (Каждое в отдельной строке)Формат выходных данныхОдно число - ответ.входные данные выходные данные4 37836856
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Фомин Илья.

n = int(input())

max_elem = 0

index = 0

for i in range(n):

   x = int(input())

   if(x >= max_elem):

       max_elem = x

       index = i + 1

print(index)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вы можете решить эту задачу на Python следующим образом:

python
# Считываем количество чисел (N) N = int(input()) # Инициализируем переменные для хранения максимального числа и его номера max_number = -1 # Используем -1 как начальное значение, так как числа будут положительными max_number_position = -1 # Считываем N чисел и находим максимальное число и его номер for i in range(N): number = int(input()) if number >= max_number: max_number = number max_number_position = i + 1 # Увеличиваем номер на 1, так как он начинается с 1, а не с 0 # Выводим номер последнего максимального числа print(max_number_position)

Этот код сначала считывает количество чисел N. Затем он вводит N целых чисел по одному, сохраняя номер последнего максимального числа. В конце он выводит этот номер.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос