Вопрос задан 25.06.2023 в 11:04. Предмет Информатика. Спрашивает Шелгунов Олег.

3. Составьте программу для решения задачи: Стоимость билета на аэробус составляет 55000 тенге.

Ежегодно стоимость билетов растет на 14%. Через сколько лет ежегодная прибыль аэробуса достигнет 1 млн тенге? Программа составляется на языке программирования Python
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Бахшиев Артем.

a = 55000

i = 0

while a < 1000000:

   a *= 1.14

   i += 1

print(i)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи вам нужно написать программу на языке Python, которая будет считать, сколько лет потребуется для того, чтобы ежегодная прибыль аэробуса достигла 1 миллиона тенге при ежегодном увеличении стоимости билетов на 14%. Мы будем использовать цикл while для этого.

Вот пример программы:

python
# Исходные данные начальная_стоимость_билета = 55000 # тенге ежегодное_увеличение = 0.14 # 14% в виде десятичной дроби цель = 1000000 # 1 миллион тенге год = 0 # начальное значение года # Используем цикл while для вычисления необходимого количества лет while начальная_стоимость_билета < цель: начальная_стоимость_билета += начальная_стоимость_билета * ежегодное_увеличение год += 1 # Выводим результат print(f"Через {год} лет ежегодная прибыль аэробуса достигнет 1 миллион тенге.")

Эта программа будет выполняться до тех пор, пока стоимость билета не достигнет или превысит 1 миллион тенге, и затем выведет количество лет, необходимых для достижения этой цели.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос