Вопрос задан 25.06.2023 в 03:04. Предмет Информатика. Спрашивает Бездушный Никита.

Напишите программу, которая запрашивает целое трёхзначное число и на экран выдаёт сколько сотен

содержится в данном числе​ помогите пожалуйста срочно
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Ерланова Балжан.

Ответ:

var a,c: integer;

begin

write('Введите значение a');

read (a);

c:=a div 100

write('Ответ c=',c);

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот простая программа на Python, которая запрашивает у пользователя трехзначное число и вычисляет количество сотен в этом числе:

python
# Запрашиваем у пользователя трехзначное число num = int(input("Введите трехзначное число: ")) # Проверяем, что введенное число является трехзначным if 100 <= num <= 999: # Вычисляем количество сотен в числе hundreds = num // 100 print(f"В числе {num} содержится {hundreds} сотен.") else: print("Пожалуйста, введите трехзначное число.")

Просто скопируйте этот код в вашу среду разработки Python или в интерпретатор Python и выполните его. После ввода трехзначного числа программа выдаст количество сотен в этом числе.

0 0

Похожие вопросы

Последние заданные вопросы в категории Информатика

Задать вопрос