Вопрос задан 04.07.2018 в 15:50. Предмет Информатика. Спрашивает Белый Максим.

Дам 25 баллов В двумерном массиве хранится информация о количестве учеников в каждом классе каждой

параллели школы с первой по одиннадцатую (в первом столбце — информация о классах первой параллели, во втором — второй параллели и т. д.). В каждой параллели школы учатся 5 классов. Составить программу для расчета общего числа учеников в любой параллели.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Павлова Виталина.

Const
  n=5; 
  m=11;
var
  a: array[1..n,1..m] of integer;
  i,j,s: integer;
begin;
  s:=0;
  writeln ('Количество учеников по классам:');
  for i:=1 to n do begin
    for j:=1 to m do begin
      a[i,j]:=random(25,30);
      write (a[i,j]:3);
    end;
    writeln;
  end;  
  writeln;
  write ('Введите номер параллели: ');
  readln (j);
  for i:=1 to n do 
    s:=s+a[i,j];
  writeln ('В ',j,'-ой параллели всего ',s,' учеников');
end.

----------------Результат:---------------------

Количество учеников по классам:
 27 27 28 26 28 25 27 25 27 29 26
 25 29 25 26 29 26 29 26 27 27 29
 30 25 29 27 25 28 29 27 29 26 28
 25 26 27 27 30 29 25 30 26 28 25
 28 26 28 27 28 28 25 27 28 26 30

Введите номер параллели: 5
В 5-ой параллели всего 140 учеников


0 0

Последние заданные вопросы в категории Информатика

Задать вопрос