Вопрос задан 24.06.2023 в 14:24. Предмет Информатика. Спрашивает Куцубей Аня.

Напишите код программы для решения задачи Написать программу, определяющую, к какой

весовойкатегории относится спортсмен:до 69 кг — легкий вес;до 85 кг – средний вес;до 105 кг – Тяжелый вес;свыше 105 кг – супертяжелый вес.Мой ответ​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Скрябина Юлия.

Ответ:

program weight_class;

var x, y:integer;

label 10,20;

 begin

   10:Writeln ('введите вес спорсмена в кг');

   Readln(x);

   if x<69 then

     Writeln('Спортсмен весом ', x, 'кг, относится к легкой категории');

   if (x>=69) and (x<85) then

   Writeln('Спортсмен весом ', x, 'кг, относится к средней категории');

   if (x>=85) and (x<105) then

   Writeln('Спортсмен весом ', x, 'кг, относится к тяжелой категории');

    if x>=105 then

   Writeln('Спортсмен весом ', x, 'кг, относится к супертяжелой категории');

   Writeln(' Будете еще вводить вес спортсмена: 1-Да, другая любая цифра-Нет');

   Readln (y);

   if y=1then

     goto 10;

  end.

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример кода на Python, который определяет весовую категорию спортсмена на основе его веса:

python
# Ввод веса спортсмена с клавиатуры weight = float(input("Введите вес спортсмена в килограммах: ")) # Определение весовой категории if weight <= 69: category = "Легкий вес" elif weight <= 85: category = "Средний вес" elif weight <= 105: category = "Тяжелый вес" else: category = "Супертяжелый вес" # Вывод результата print(f"Спортсмен относится к категории: {category}")

Вы можете ввести вес спортсмена, и программа определит его весовую категорию на основе указанных условий.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос