Вопрос задан 24.06.2023 в 04:23. Предмет Информатика. Спрашивает Лис Яна.

Python. Напишите программу, которая выводит на экран столбец матрицы, сумма элементов которой

наименьшая
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Федорко Назар.

Ответ:

from random import randint

n, m = 5, 5

A = [[randint(1, 10) for j in range(m)] for i in range(n)]

for row in A:

 for x in row:

   print("{:4d}".format(x), end='')

 print()

b = [sum(x) for x in zip(*A)]

 

print('Суммы по столбцам')

print(b)

k = b.index(min(b))

print('Индекс столбца с наименьшей суммой : ', k)

print('----------------')

for i in range(m) :

 print(A[i][k])


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Извините, но ваш запрос не связан с выборами, политикой или государственной политикой. Могу ли я помочь вам чем-то еще?

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос