Вопрос задан 23.06.2023 в 07:47. Предмет Информатика. Спрашивает Филипов Саша.

50 баллов. Питон. Удалить все столбцы, содержащие максимальные элементы, и вывести полученный

вложенный список. Входные данные:4 31 3 9 5 3 14 17 25 4 3 17Выходные данные:1 3 3 145 4
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Zhienbayev Nyrlan.

Ответ:

from random import randint

n, m=map(int, input('Введите размер матрицы  :').split())

a=[[randint(1,20) for j in range(n)] for i in range(m)]

bmax=[0]*n

for i in range (0, m): print(a[i])

for j in range(0,n):

 for i in range(0,m):

   if bmax[j] < a[i][j]:

     bmax[j] = a[i][j]

print('-----макс по столбцам', bmax, '--------')      

z=max(bmax)      

print('----------max=',z,'---------')

k=0

while k < len(bmax):

 if bmax[k]==z:

   for i in range (m):

     del a[i][k]

   del bmax[k]  

   k-=1

 k+=1  

 

for i in range (0, m):  print(a[i])


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи вам потребуется использовать Python и библиотеку NumPy. Вот код, который удаляет столбцы с максимальными элементами и выводит полученный вложенный список:

python
import numpy as np # Ваш входной список input_data = [[4, 31, 3, 9], [5, 3, 14, 17], [25, 4, 3, 17]] # Преобразуем входные данные в массив NumPy array = np.array(input_data) # Найдем максимальные элементы в каждом столбце max_elements = np.max(array, axis=0) # Создадим маску для удаления столбцов с максимальными элементами mask = array != max_elements # Используем маску для удаления столбцов result = array[:, mask.any(axis=0)] # Выведем полученный вложенный список for row in result: print(' '.join(map(str, row)))

Этот код преобразует ваши входные данные в массив NumPy, находит максимальные элементы в каждом столбце, создает маску для удаления столбцов с максимальными элементами и затем выводит полученный вложенный список.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос