Вопрос задан 23.06.2023 в 00:54. Предмет Информатика. Спрашивает Кузьмин Андрей.

На Питоне! Срочно! Напишите программу, которая будет считать суммы положительных и отрицательных

чисел отдельно. Пользователь будет вводить число, а программа будет проверять: если число больше нуля, то программа добавляет его к сумме положительных. Иначе, добавляет к сумме отрицательных. Всего программа будет проверять 5 чисел, а после этого выводить два числа: сумму всех положительных чисел и сумму всех отрицательных.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Пржегарлинский Дима.

Ответ:

s1 = 0

s2 = 0

for i in range(5):

   a = int(input())

   if a < 0:

       s1 = s1 + a

   elif a > 0:

       s2 = s2 + a

print(s1, s2)

Не забудь проставить табуляцию, знания любят пробелы съедать.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот программа на Python, которая делает то, что вы описали:

python
sum_positive = 0 sum_negative = 0 for i in range(5): number = float(input("Введите число: ")) if number > 0: sum_positive += number else: sum_negative += number print("Сумма положительных чисел:", sum_positive) print("Сумма отрицательных чисел:", sum_negative)

Эта программа просит пользователя ввести 5 чисел, после чего она суммирует положительные и отрицательные числа отдельно и выводит результаты на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос