
Решите с помощью pascal 1. Найти сумму чисел, которые оканчиваются на 9. Программа получает на
вход количество чисел в последовательности, а затем сами числа. 2. Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. 3. Пользователь вводит два целых числа A и B (А 4. Даны натуральные числа от 101 до 321. Напечатать те из них, которые делятся БЕЗ ОСТАТКА на 4, но не делятся на 6.

Ответы на вопрос

1)
var
n,x,s,i : integer;
begin
s:=0;
write('Введите n: '); read(n);
for i:=1 to n do
begin
write('X - ', i, ' = '); read(x);
if x mod 10 = 9 then
s:=s+n;
end;
writeln('Сумма с 9 на конце = ', s);
end.
2)
var
n,i,max,x : integer;
begin
max:=0;
write('Введите n: '); read(n);
for i:=1 to n do
begin
if (x > max) and (x mod 5 = 0) then
max:=x;
write('X - ',i,' = '); read(x);
end;
writeln('Максимальное, кратное 5 = ', max);
end.
3)
var
a,b,i : integer;
begin
write('a = '); read(a);
write('b = '); read(b);
for i:=a to b do
begin
if (i mod 4 = 0) and (i mod 6 <> 0) then
writeln(i);
end;
end.



Конечно, вот Pascal-код для каждой из задач:
- Найти сумму чисел, которые оканчиваются на 9:
pascalprogram SumNumbersEndingWith9; var n, num, sum: integer; i: integer; begin sum := 0; write('Введите количество чисел: '); readln(n); for i := 1 to n do begin write('Введите число: '); readln(num); if (num mod 10 = 9) then sum := sum + num; end; writeln('Сумма чисел, оканчивающихся на 9: ', sum); end.
- Определить максимальное число, кратное 5:
pascalprogram MaxNumberDivisibleBy5; var n, num, maxNum: integer; i: integer; begin maxNum := -1; write('Введите количество чисел: '); readln(n); for i := 1 to n do begin write('Введите число: '); readln(num); if (num mod 5 = 0) and (num > maxNum) then maxNum := num; end; if maxNum = -1 then writeln('В последовательности нет чисел, кратных 5') else writeln('Максимальное число, кратное 5: ', maxNum); end.
- Печать чисел от 101 до 321, которые делятся без остатка на 4, но не делятся на 6:
pascalprogram NumbersDivisibleBy4NotBy6; var i: integer; begin for i := 101 to 321 do begin if (i mod 4 = 0) and (i mod 6 <> 0) then writeln(i); end; end.
Эти программы решают указанные задачи в Pascal. Вы можете ввести данные и запустить их в среде Pascal для получения результатов.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili