Вопрос задан 22.06.2023 в 21:19. Предмет Информатика. Спрашивает Чиорба Серега.

Написать программу, используя массивы. Дана квадратная матрица порядка M. Заменить нулями элементы

матрицы, лежащие ниже побочной диагонали. python
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кудра Роман.

Ответ:

from random import randint

n=int(input('Введите размер матрицы  :'))

a=[[randint(1,20) for j in range(n)] for i in range(n)]

for i in range (0, n): print(a[i])

print('------------ после замены --------------')

for i in range (0, n):

 for j in range(0, i):

   a[i][j]=0

for i in range (0, n): print(a[i])


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на Python, которая заменяет нулями элементы матрицы, лежащие ниже побочной диагонали:

python
def zero_below_secondary_diagonal(matrix): M = len(matrix) for i in range(M): for j in range(M): if i + j >= M: matrix[i][j] = 0 # Пример использования: matrix = [ [1, 2, 3], [4, 5, 6], [7, 8, 9] ] zero_below_secondary_diagonal(matrix) for row in matrix: print(row)

Эта программа определяет функцию zero_below_secondary_diagonal, которая проходит по всем элементам матрицы и заменяет нулями те, которые находятся ниже побочной диагонали (где i + j >= M, где M - размерность матрицы). В конечном итоге, элементы матрицы ниже побочной диагонали заменяются нулями.

0 0

Похожие вопросы

Последние заданные вопросы в категории Информатика

Задать вопрос