Вопрос задан 22.06.2023 в 14:12.
Предмет Информатика.
Спрашивает Лукьянова Настя.
ПРОГРАММИРОВАНИЕ НА С++ ПОМОГИТЕ ПОЖАЛУЙСТА!!!!!! Найти сумму всех отрицательных элементов
двумерного массива, кроме элементов с номерами от K до L включительно в заданной строке С.Ответы на вопрос
Отвечает Суздалева Лада.
int main()
{
// 2м-ый массив
const size_t n = 6, m = 9;
float mas[n][m];
// K, L и C
const size_t k, l, c;
// сумма
double sum = 0;
// проходимся по массиву
for (int y = 0; y < m; y++)
{
for (int x = 0; x < n; x++)
{
if (y == c and k <= x and x <= l)
continue;
if (mas[x][y] < 0)
sum += mas[x][y];
}
}
// в sum ответ
sum;
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я могу помочь вам написать программу на C++, которая найдет сумму всех отрицательных элементов двумерного массива, кроме элементов с номерами от K до L включительно в заданной строке C. Давайте начнем с кода:
cpp#include <iostream>
int main() {
int n, m;
std::cout << "Введите количество строк: ";
std::cin >> n;
std::cout << "Введите количество столбцов: ";
std::cin >> m;
// Создаем двумерный массив
int** arr = new int*[n];
for (int i = 0; i < n; i++) {
arr[i] = new int[m];
}
// Заполняем массив
std::cout << "Введите элементы массива:" << std::endl;
for (int i = 0; i < n; i++) {
for (int j = 0; j < m; j++) {
std::cin >> arr[i][j];
}
}
int row;
std::cout << "Введите номер строки C (нумерация с 0): ";
std::cin >> row;
int k, l;
std::cout << "Введите номера K и L: ";
std::cin >> k >> l;
int sum = 0;
if (row >= 0 && row < n && k >= 0 && k < m && l >= 0 && l < m) {
for (int j = 0; j < m; j++) {
if (j < k || j > l || j == k || j == l) {
if (arr[row][j] < 0) {
sum += arr[row][j];
}
}
}
std::cout << "Сумма отрицательных элементов в строке " << row << ": " << sum << std::endl;
} else {
std::cout << "Введены некорректные данные." << std::endl;
}
// Освобождаем выделенную память
for (int i = 0; i < n; i++) {
delete[] arr[i];
}
delete[] arr;
return 0;
}
Этот код позволит вам ввести размеры двумерного массива, его элементы, а затем найти сумму отрицательных элементов в заданной строке C, исключая элементы с номерами от K до L включительно.
Похожие вопросы
Информатика 25
Информатика 328
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
