Вопрос задан 22.06.2023 в 10:02.
Предмет Информатика.
Спрашивает Ильина Дарья.
Составить программу на с# 1.В компьютер вводятся два числа. Если первое больше второго, то
вычислить их сумму, иначе - произведение. 2.Вывести дни недели через оператора выбора Switch. 3. Найти наибольшее число из трех значений x,y,z;Ответы на вопрос
Отвечает Воробьева Лариса.
Ответ:
Объяснение:
Все ответы в текстовых файлах. Все работают проверял. Код может быть по-колхозному ибо я программирую на с++.



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для выполнения этих задач вам потребуется написать C# программу. Вот пример решения каждой из задач:
- Вычисление суммы или произведения в зависимости от отношения чисел:
csharpusing System;
class Program
{
static void Main()
{
Console.Write("Введите первое число: ");
double number1 = Convert.ToDouble(Console.ReadLine());
Console.Write("Введите второе число: ");
double number2 = Convert.ToDouble(Console.ReadLine());
if (number1 > number2)
{
double sum = number1 + number2;
Console.WriteLine($"Сумма чисел: {sum}");
}
else
{
double product = number1 * number2;
Console.WriteLine($"Произведение чисел: {product}");
}
}
}
- Вывод дней недели через оператор
switch:
csharpusing System;
class Program
{
static void Main()
{
Console.Write("Введите номер дня недели (1-7): ");
int dayOfWeek = Convert.ToInt32(Console.ReadLine());
switch (dayOfWeek)
{
case 1:
Console.WriteLine("Понедельник");
break;
case 2:
Console.WriteLine("Вторник");
break;
case 3:
Console.WriteLine("Среда");
break;
case 4:
Console.WriteLine("Четверг");
break;
case 5:
Console.WriteLine("Пятница");
break;
case 6:
Console.WriteLine("Суббота");
break;
case 7:
Console.WriteLine("Воскресенье");
break;
default:
Console.WriteLine("Неверный номер дня недели.");
break;
}
}
}
- Нахождение наибольшего числа из трех:
csharpusing System;
class Program
{
static void Main()
{
Console.Write("Введите значение x: ");
double x = Convert.ToDouble(Console.ReadLine());
Console.Write("Введите значение y: ");
double y = Convert.ToDouble(Console.ReadLine());
Console.Write("Введите значение z: ");
double z = Convert.ToDouble(Console.ReadLine());
double max = Math.Max(x, Math.Max(y, z));
Console.WriteLine($"Наибольшее число: {max}");
}
}
Вы можете скопировать каждую из этих программ в среду разработки C# (например, Visual Studio) и выполнить их для получения результатов.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 38
Информатика 45
Информатика 24
Информатика 39
Информатика 16
Информатика 30
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
