
Написать программу c++ cin cout (Двумерные массивы) Условие Требуется определить количество
способов выплаты n рублей монетами по 1, 2, 5 и 10 рублей. входные данные выходные данные 13 16 42 220 5 4

Ответы на вопрос

#include <iostream>
using namespace std;
int a[4] = {1, 2, 5, 10}, b = sizeof(a)/sizeof(a[0]), m[100];
int f(int s, int j = 0, int k = 0) {
if (j >= b || s < 0)
return 0;
else if (s == 0) {
for(int i=0; i<k; i++)
return 1;
} else {
m[k]=a[j];
return f(s - a[j], j, k + 1) + f(s, j + 1, k);
}
}
int main() {
int n; cin >> n;
cout << f(n);
}



Вы можете написать программу на C++, чтобы решить эту задачу с использованием динамического программирования. Программа будет вычислять количество способов выплаты n рублей монетами 1, 2, 5 и 10 рублей. Вот C++ код для этой задачи:
cpp#include <iostream>
#include <vector>
using namespace std;
int countWaysToPay(int n) {
vector<int> coins = {1, 2, 5, 10};
vector<int> dp(n + 1, 0);
dp[0] = 1; // 1 способ выплаты 0 рублей - ничего не делать
for (int i = 0; i < coins.size(); i++) {
for (int j = coins[i]; j <= n; j++) {
dp[j] += dp[j - coins[i]];
}
}
return dp[n];
}
int main() {
int n;
cout << "Введите сумму n: ";
cin >> n;
int ways = countWaysToPay(n);
cout << "Количество способов выплаты " << n << " рублей: " << ways << endl;
return 0;
}
После ввода суммы n (например, 13), программа выведет количество способов выплаты этой суммы монетами 1, 2, 5 и 10 рублей.
Примеры входных и выходных данных, которые вы предоставили, также подтверждают правильность работы программы.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili