Вопрос задан 21.06.2023 в 21:31. Предмет Информатика. Спрашивает Ревенко Ярослав.

Программа python. Напишите программу, которая в последовательности натуральных чисел определяет

количество чисел, оканчивающихся на 9. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 9. Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: количество чисел, оканчивающихся на 9. Пример работы программы: Входные данные 3 19 29 24 Выходные данные 2
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Брикало Татьяна.

Программа:
Python:

N, count = int(input()), 0

for i in range(N):

   number = int(input())

   if number % 10 == 9:

       count += 1

print(count)

Объяснение:

В начале регистрируются переменные N, count. N - кол-во чисел в последовательности, которое вводится с клавиатуры; count - кол-во чисел, оканчивающихся на 9.

С помощью цикла for выполняем тело N раз. Вводится число с клавиатуры number и сразу же анализируется - если остаток деления на 10 равен 9, то count увеличивается на 1. При окончании цикла выводится значение count.

Результат:

3

19

27

10819

2

4

8375629

26672

123

94829

2

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Python, которая решает данную задачу:

python
def count_numbers_ending_with_9(sequence_length, numbers): count = 0 for i in range(sequence_length): if numbers[i] % 10 == 9: count += 1 return count # Ввод данных sequence_length = int(input("Введите количество чисел в последовательности: ")) numbers = [] print("Введите числа:") for _ in range(sequence_length): num = int(input()) numbers.append(num) # Вызов функции и вывод результата result = count_numbers_ending_with_9(sequence_length, numbers) print("Количество чисел, оканчивающихся на 9:", result)

Вы можете ввести этот код в среде разработки Python или скопировать его в интерактивную среду, чтобы проверить его работу. Программа сначала запрашивает количество чисел в последовательности, затем вводит сами числа, и, наконец, выводит количество чисел, оканчивающихся на 9.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос