Вопрос задан 21.06.2023 в 19:02.
Предмет Информатика.
Спрашивает Меркель Елена.
На языке ПАСКАЛЬ 1. Составить программу, которая сформирует двумерный массив, состоящий из 3-х
строк и 4-х столбцов из целых случайных чисел из интервала (-50;50) и выведет на экран в виде таблицы. 2. Составить программу, которая сформирует одномерный массив из 10 целых случайных чисел из интервала (-20;20), определит сумму всех элементов массива, найдет максимальное и минимальное значения.Ответы на вопрос
Отвечает Котик Аня.
Ответ:
1)
Program z1;
var i,j:integer;
a:array[1..3,1..4] of integer;
begin
for i:=1 to 3 do begin
for j:=1 to 4 do begin
a[i,j]:=random(101)-50;
write(a[i,j]:5);
end;
writeln();
end;
end.
2)
Program z2;
var i,j,max,min,sum:integer;
a:array[1..10] of integer;
begin
min:=1000;
for i:=1 to 10 do begin
a[i]:=random(41)-20;
print(a[i]);
sum:=sum+a[i];
if(a[i] > max) then max:=a[i];
if(a[i] < min) then min:=a[i];
end;
writeln();
writeln('Сумма: ',sum);
writeln('Максимальное: ',max);
writeln('Минимальное: ',min);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Паскаль для выполнения задач 1 и 2:
- Программа для создания и вывода двумерного массива:
pascalprogram TwoDimensionalArray; var arr: array[1..3, 1..4] of integer; i, j: integer; begin randomize; // Инициализация генератора случайных чисел // Заполняем массив случайными числами из интервала (-50;50) for i := 1 to 3 do for j := 1 to 4 do arr[i, j] := random(101) - 50; // Выводим массив в виде таблицы for i := 1 to 3 do begin for j := 1 to 4 do write(arr[i, j]:4); writeln; end; readln; end.
- Программа для создания и анализа одномерного массива:
pascalprogram OneDimensionalArray; var arr: array[1..10] of integer; i, sum, max, min: integer; begin randomize; // Инициализация генератора случайных чисел // Заполняем массив случайными числами из интервала (-20;20) for i := 1 to 10 do arr[i] := random(41) - 20; // Инициализируем переменные для суммы, максимума и минимума sum := 0; max := arr[1]; min := arr[1]; // Вычисляем сумму, максимум и минимум for i := 1 to 10 do begin sum := sum + arr[i]; if arr[i] > max then max := arr[i]; if arr[i] < min then min := arr[i]; end; // Выводим результаты writeln('Массив:'); for i := 1 to 10 do write(arr[i]:4); writeln; writeln('Сумма элементов: ', sum); writeln('Максимальное значение: ', max); writeln('Минимальное значение: ', min); readln; end.
Эти программы создадут и заполнят массивы случайными числами, а также выполнят необходимые вычисления и вывод результатов.
Похожие вопросы
Информатика 25
Информатика 330
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 34
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
