
Помогите пж дополнить программу в паскале так, чтобы в введенном предложении пропадала не только
русская буква "о", но и "О". Само задание, которое нужно было выполнить: Составить программу на Паскале, которая удалит все буквы «о» из текста, который состоит из 6 слов. Мой ответ: var a:string; i:integer; begin writeln('Введите предложение из 6 слов'); readln(a); for i:= 1 to 6 do if a[i] = 'о' then delete(a,i,1); writeln(a); end В чем ошибка и что нужно добавить? Помогите!!! Даю 58 баллов!

Ответы на вопрос

Ответ:
(см. объяснение)
Объяснение:
Приведенная вами задача решается на паскале в одну строчку кода:
##
ReadString.Where(x->(x<>'О') and (x<>'о')).Print;
Или еще один способ:
##
Regex.Replace(ReadString, 'о|О', '').Print;
Как видите, делать так, как вы не только не обязательно, но и неправильно. Пожалуйста, пользуйтесь современными возможностями языка. Код успешно выполнился на версии: 3.8 2899.
Возвращаясь к вашему решению:
- Вы смотрите первые 6 символов, а не слов.
- Каждый раз, когда вы удаляете символ, происходит смещение индексов на один. Подобная неосторожность приводит к ошибке "Индекс находится вне границ массива".
Учитывая все выше сказанное, получаем, что ваш код должен выглядеть так:
var a: string;
i, k: integer;
begin
writeln('Введите предложение из 6 слов');
readln(a);
k:= 0;
for i:= 1 to length(a) do
if((a[i-k] = 'о') or (a[i-k] = 'О')) then
begin
delete(a,i-k,1);
k:= k+1;
end;
writeln(a);
end.
Здоровье кода такой программы по оценке компилятора равно 56%. Это означает, что выбранный вами стиль написания программ уже давно очень сильно устарел и не является грамотным. Но в логике и реализации ошибок теперь нет.
Задание выполнено!



В вашей программе не учитывается большая буква "О". Чтобы удалить как маленькую, так и большую "о" из введенного предложения, вы можете использовать функцию Pos
для поиска позиции символа в строке и затем удалить его, если он найден. Вот исправленный вариант программы:
pascalvar a: string; i: integer; begin writeln('Введите предложение из 6 слов'); readln(a); a := LowerCase(a); // Преобразуем всю строку к нижнему регистру for i := 1 to 6 do begin if (a[i] = 'о') or (a[i] = 'о') then delete(a, i, 1); end; writeln(a); end.
Этот код сначала преобразует всю строку в нижний регистр с помощью LowerCase
, а затем проверит каждый символ в строке на равенство "о" или "О". Если символ соответствует одной из этих букв, он будет удален с помощью delete
.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili