Задание 5. Составьте программу, которая генерирует случайное четы- рехзначное число от 1000 до 9999
(номер автобусного билета), выводит его на экран и определяет, является ли билет «счастливым» (сумма первых двух цифр равна сумме последних двух цифр). ВНИМАНИЕ ЯЗЫК ПАСКАЛЬОтветы на вопрос
var
n:integer;
begin
n:=random(9000)+1000;
writeln(n);
if n div 1000 + n div 100 mod 10 = n mod 10 + n mod 100 div 10 then
writeln('Happy ticket')
else writeln('Oooops');
end.
Конечно, вот пример программы на языке Паскаль, которая генерирует случайное четырехзначное число (номер автобусного билета), выводит его на экран и определяет, является ли билет "счастливым" (сумма первых двух цифр равна сумме последних двух цифр):
```pascal program LuckyBusTicket;
var ticketNumber, firstHalf, secondHalf, sumFirst, sumSecond: integer;
begin Randomize; // инициализация генератора случайных чисел
// Генерация случайного числа от 1000 до 9999 ticketNumber := Random(9000) + 1000; // Вывод сгенерированного числа writeln('Номер билета: ', ticketNumber); // Разделение номера на две части firstHalf := ticketNumber div 100; secondHalf := ticketNumber mod 100;
// Вычисление сумм цифр в каждой части sumFirst := (firstHalf div 10) + (firstHalf mod 10); sumSecond := (secondHalf div 10) + (secondHalf mod 10); // Проверка на счастливый билет if sumFirst = sumSecond then writeln('Это счастливый билет!') else writeln('Этот билет не счастливый.'); end. ```
Эта программа использует функцию `Randomize`, чтобы инициализировать генератор случайных чисел, затем создает случайное четырехзначное число. Далее она разделяет это число на две части, вычисляет суммы цифр в каждой части и затем проверяет, равны ли эти суммы. Если суммы равны, программа выводит, что билет счастливый, иначе выводит, что билет не счастливый.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
