Вопрос задан 20.06.2023 в 20:11.
Предмет Информатика.
Спрашивает Шапран Никита.
Задача на PascalABC.net нужно написать программу: На праздник был устроен конкурс. В конкурсе
участвовало N человек. Известен рост каждого (А[i]). Нужно узнать количество человек которые равны самому высокому человеку не считая его самого.ограничения:1 < = N < = 10000, 1 < = A = 1000Ответы на вопрос
Отвечает Мещерякова Софья.
Ответ:
На праздник был устроен конкурс. В конкурсе участвовало N человек. Известен, рост каждого (A[I]). Нужно узнать количество человек, рост которых равен росту самого высокого (не считая его самого). Ограничение: 1<=N<=10000, 1<=A<=10000 Формат ввода: N, A[1], A[2], ... , A[N] Формат вывода: KOL - количество человек, которые равны самому высокому не считая его самого. Пример ввода: 5 100 200 300 300 300 Пример вывода: 2
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на PascalABC.NET, которая решает данную задачу:
pascalprogram Contest; var N, i, maxHeight, count: integer; A: array[1..10000] of integer; begin // Вводим количество участников write('Введите количество участников (N): '); readln(N); // Вводим рост каждого участника writeln('Введите рост участников:'); for i := 1 to N do begin write('A[', i, ']: '); readln(A[i]); end; // Находим самый высокий рост maxHeight := A[1]; for i := 2 to N do begin if A[i] > maxHeight then maxHeight := A[i]; end; // Считаем количество участников, равных самому высокому, не считая его самого count := 0; for i := 1 to N do begin if (A[i] = maxHeight) and (i <> 1) then Inc(count); end; // Выводим результат writeln('Количество участников, равных самому высокому (не считая его самого): ', count); end.
Эта программа запрашивает у пользователя количество участников и их рост, затем находит самый высокий рост и подсчитывает количество участников с таким же ростом (не считая самого высокого).
Похожие вопросы
Информатика 81
Информатика 97
Информатика 57
Информатика 157
Информатика 49
Информатика 66
Информатика 50
Информатика 65
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
