
Составить программу, которая в зависимости от порядкового номера месяца (1,2,...,12) выводит на
экран количество дней в этом месяце. Год может быть високосным ( информация об этом вводится с клавиатуры ) В С++ пж 30 баллов

Ответы на вопрос

Ответ:
Объяснение:
#include <iostream>
#include <cstdlib>
using namespace std;
int main() {
setlocale(0, "");
int q = 28, w = 30, e = 31,a;
cout << "Введите номер месяца:";
cin >> a;
if (a < 1){ cout << "Ошибка ввода месяца" << endl; }
if (a < 2){ cout << "Количество дней в месяце: " << e << endl; }
else if (a < 3){ cout << "Количество дней в месяце: " << q << endl; }
else if (a < 4){ cout << "Количество дней в месяце: " << e << endl; }
else if (a < 5){ cout << "Количество дней в месяце: " << w << endl; }
else if (a < 6){ cout << "Количество дней в месяце: " << e << endl; }
else if (a < 7){ cout << "Количество дней в месяце: " << w << endl; }
else if (a < 8){ cout << "Количество дней в месяце: " << e << endl; }
else if (a < 9){ cout << "Количество дней в месяце: " << e << endl; }
else if (a < 10){ cout << "Количество дней в месяце: " << w << endl; }
else if (a < 11){ cout << "Количество дней в месяце: " << e << endl; }
else if (a < 12){ cout << "Количество дней в месяце: " << w << endl; }
else if (a < 13){ cout << "Количество дней в месяце: " << e << endl; }
else if (a > 12){ cout << "Ошибка ввода месяца" << endl; }
system("pause");
return 0;



Программа на языке C++:
```c++
#include
int main() { int month, year; cout << "Введите порядковый номер месяца (1-12): "; cin >> month;
cout << "Введите год: "; cin >> year;
int daysInMonth;
if (month == 2) { if ((year % 4 == 0 && year % 100 != 0) || year % 400 == 0) { daysInMonth = 29; // Високосный год } else { daysInMonth = 28; // Не високосный год } } else if (month == 4 || month == 6 || month == 9 || month == 11) { daysInMonth = 30; // Месяцы с 30 днями } else { daysInMonth = 31; // Остальные месяцы }
cout << "Количество дней в этом месяце: " << daysInMonth << endl;
return 0; } ```
Эта программа сначала запрашивает у пользователя порядковый номер месяца и год. Затем, используя условные операторы, определяет количество дней в этом месяце, учитывая информацию о високосных годах. Результат выводится на экран.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili