Вопрос задан 20.06.2023 в 07:00. Предмет Информатика. Спрашивает Постовалова Полина.

Напишите программу к следующему условию. С клавиатуры вводятся 10 целых чисел. Все положительные

числа перемножаются между собой. ​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Козко Софья.

Ответ:

add = 1 # Счётчик, в который будет записывать общее произведение.

for i in range(1, 10 + 1): # Цикл от одного до десяти.

   a = int(input()) # Каждый раз присваиваем новое значение.

   if a > 0: add *= a # Если число положительное, умножаем его на счётчик.

print('Произведение всех чисел = ' + str(add), end=".") # Выводим результат.

Объяснение:

Написал на питоне, но, надеюсь, смысл передать смог.


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке Python, которая решает данную задачу:

```python # Вводим 10 целых чисел с клавиатуры numbers = [] for i in range(10): number = int(input("Введите целое число: ")) numbers.append(number)

# Инициализируем переменную для хранения произведения положительных чисел product = 1

# Перебираем числа и перемножаем только положительные числа for number in numbers: if number > 0: product *= number

# Выводим результат print("Произведение положительных чисел:", product) ```

Программа запрашивает у пользователя ввод 10 целых чисел с клавиатуры. Затем она перебирает эти числа и перемножает только положительные числа. Результат выводится на экран.

Примечание: В данном примере использован язык программирования Python, но вы можете использовать любой другой язык программирования, с которым вам удобно работать.

Надеюсь, это поможет! Если у вас возникнут дополнительные вопросы, не стесняйтесь задавать.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос