Написать программу в Pascal, которая печатает значение логического выражения TRUE или FALSE, в
зависимости от ложности или истинности следующего утверждения: Средняя цифра трехзначного числа в два раза больше суммы первойи третьей цифр.Ответы на вопрос
var
a, b, c, d: integer;
begin
read(a);
b := a div 100;
c := a div 10 mod 10;
d := a mod 10;
if (c / 2) = (b + d) then writeln('TRUE')
else writeln('FALSE')
end.
Для решения данной задачи нужно выполнить следующие шаги:
1. Запросить у пользователя трехзначное число. 2. Получить отдельные цифры данного числа. 3. Вычислить среднюю цифру, сумму первой и третьей цифр и умножить ее на 2. 4. Сравнить полученные значения: если они равны, то вывести значение true, иначе false.
Пример кода на языке Pascal:
``` program CheckNumber;
var number, digit1, digit2, digit3, avgDigit, sum: Integer; result: Boolean; begin // Шаг 1: запрос числа Write('Введите трехзначное число: '); Readln(number); // Шаг 2: получение цифр числа digit1 := number div 100; // первая цифра digit2 := (number div 10) mod 10; // вторая цифра digit3 := number mod 10; // третья цифра // Шаг 3: вычисление значений avgDigit := (digit1 + digit3) * 2; // средняя цифра вдвое больше суммы первой и третьей // Шаг 4: сравнение значений result := (avgDigit = digit2); // Вывод результата if result then WriteLn('Результат: true') else WriteLn('Результат: false');
end. ```
После выполнения программы она запросит трехзначное число у пользователя и выведет значение true или false в зависимости от истинности или ложности утверждения.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
