Вопрос задан 19.06.2023 в 17:40. Предмет Информатика. Спрашивает Мятова Софья.

Составить программу ввода чисел в строку через пробел. После нажатия на Enter, на экран выводится

сумма. Далее пользователь может снова вводитьчисла. Их сумма будет добавляться к уже посчитанной, и итог выводиться наэкран. Когда вместо чисел вводится специальный символ, программа заверша-ется.​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Смирнов Евгений.

Ответ:

Python

Объяснение:

total = 0

while True:

   input_list = input().split(' ')

   try:

       total  += sum(map(int, input_list))

       print(total)

   except ValueError:

       break

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Приведенный ниже код написан на языке программирования Python и выполняет задачу, описанную в вашем вопросе. Он позволяет пользователю вводить числа через пробел, после чего выводит сумму введенных чисел. Программа продолжает принимать числа и добавлять их сумму к предыдущей, пока пользователь не введет специальный символ (например, "q" или "exit").

```python def main(): total_sum = 0 while True: user_input = input("Введите числа через пробел (или 'q' для завершения): ") # Проверка на завершение программы if user_input.lower() == 'q': break # Разбиваем введенную строку на числа numbers = [float(num) for num in user_input.split() if num.replace('.', '').isdigit()] # Суммируем числа и добавляем к общей сумме current_sum = sum(numbers) total_sum += current_sum # Выводим результат print(f"Сумма чисел: {current_sum}") print(f"Общая сумма: {total_sum}\n")

if __name__ == "__main__": main() ```

Обратите внимание, что в этом коде используется проверка на ввод чисел с плавающей точкой (float), поэтому программа может обрабатывать десятичные числа. Она также проверяет ввод на наличие специального символа ('q' в данном случае) для завершения выполнения программы.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос