(В паскале) Случайным образом вводится номер месяца, выдать его название. дам 25 баллов, если
всё правильно будетОтветы на вопрос
Ответ:
(см. объяснение)
Объяснение:
Решение в 1 строчку кода:
##
seq('Январь', 'Февраль', 'Март', 'Апрель', 'Май', 'Июнь', 'Июль', 'Август', 'Сентябрь', 'Октябрь', 'Ноябрь', 'Декабрь').ElementAt(ReadInteger - 1).Print;
Возможно также решение через case или if.
Задание выполнено!
Відповідь:
Пояснення:
program ;
var a: integer;
begin
writeln('ââåäèòå ÷èñëî ìåñÿöà');
readln(a);
if a=1 then writeln('ñåé÷àñ ÿíâàðü');
if a=2 then writeln('ñåé÷àñ ôåâðàëü');
if a=3 then writeln('ñåé÷àñ ìàðò');
if a=4 then writeln('ñåé÷àñ àïðåëü');
if a=5 then writeln('ñåé÷àñ ìàé');
if a=6 then writeln('ñåé÷àñ èþíü');
if a=7 then writeln('ñåé÷àñ èþëü');
if a=8 then writeln('ñåé÷àñ ');
if a=9 then writeln('ñåé÷àñ ñåíòÿáðü');
if a=10 then writeln('ñåé÷àñ îêòÿáðü');
if a=11 then writeln('ñåé÷àñ íîÿáðü');
if a=12 then writeln('ñåé÷àñ äåêàáðüü');
readln;
end.
Конечно, я могу помочь вам написать программу на языке Pascal (Delphi), которая случайным образом вводит номер месяца и выводит его название. Вот пример кода:
```pascal program MonthName;
var monthNumber: Integer;
begin // Ввод случайного номера месяца Randomize; // Инициализация генератора случайных чисел monthNumber := Random(12) + 1; // Генерация случайного числа от 1 до 12
// Вывод номера месяца writeln('Номер месяца: ', monthNumber);
// Вывод названия месяца в зависимости от его номера case monthNumber of 1: writeln('Январь'); 2: writeln('Февраль'); 3: writeln('Март'); 4: writeln('Апрель'); 5: writeln('Май'); 6: writeln('Июнь'); 7: writeln('Июль'); 8: writeln('Август'); 9: writeln('Сентябрь'); 10: writeln('Октябрь'); 11: writeln('Ноябрь'); 12: writeln('Декабрь'); end;
readln; end. ```
Программа использует генератор случайных чисел для выбора случайного номера месяца от 1 до 12. Затем она использует оператор `case` для вывода названия месяца в зависимости от сгенерированного номера.
Пожалуйста, скопируйте этот код в среду программирования Pascal (например, Lazarus или Delphi) и запустите его. Если у вас есть дополнительные вопросы или требуется дополнительное объяснение, не стесняйтесь спрашивать!
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
