Вопрос задан 24.01.2020 в 08:09.
Предмет Информатика.
Спрашивает Мишин Михаил.
Решить задачи в Паскале1. Вводится число от 1 до 10. Дать название этого числа (1 - один , 2 - два
, …, 10 - десять); 2. Вводится число от 1 до 7, определяющее день недели. Дать название этого дня (1 - понедельник, 2 - вторник, …, 7 - воскресенье); 3. В спортивных соревнованиях Шарик, кот Матроскин, дядя Фёдор и почтальон Печкин заняли соответственно 1, 2, 3 и 4 места. Составить программу, которая по номеру места выдаёт имя участника соревнований. 4. Вводится число от 1 до 15. Вывести данное число, записанное римскими цифрами (I, II, III, IV, V, VI, …., XV); 6. Вводится число от 1 до 15. Вывести данное число, записанное в двоичной системе счисления (1, 10, 11, 100, 101, …., 1111);Ответы на вопрос
Отвечает Кутяев Никита.
Var a:integer;
begin
readln(a)
if a:=1 then writeln('1 - один');
if a:=2 then writeln('2 - два');
if a:=3 then writeln('3 - три');
if a:=4 then writeln('4 - четыре');
. . .{по аналогии}
end.
2)Абсолятно то же самое что и в предыдущем номере, просто тепрь писать 1 - понедельник, 2 - вторник...
3)var a:integer;
if a:=1 then writeln('Sharik');
if a:=2 then writeln('kot');
if a:=3 then writeln('Fedor');
if a:=4 them writeln('Pechkin');
end.
4) и 6) выполняются по аналогии.
Если не понимаешь, я объясню в комментариях.
begin
readln(a)
if a:=1 then writeln('1 - один');
if a:=2 then writeln('2 - два');
if a:=3 then writeln('3 - три');
if a:=4 then writeln('4 - четыре');
. . .{по аналогии}
end.
2)Абсолятно то же самое что и в предыдущем номере, просто тепрь писать 1 - понедельник, 2 - вторник...
3)var a:integer;
if a:=1 then writeln('Sharik');
if a:=2 then writeln('kot');
if a:=3 then writeln('Fedor');
if a:=4 them writeln('Pechkin');
end.
4) и 6) выполняются по аналогии.
Если не понимаешь, я объясню в комментариях.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
