Написать программу для решения задачи: даны 2 числа a и b. Увеличить а в 2 раза, если оно больше b,
иначе b уменьшить на 2Ответы на вопрос
Відповідь:
#include<iostream>
int main(){
double a,b;
std::cout<<"Enter a:\n";
std::cin>>a;
std::cout<<"Enter b:\n";
std::cin>>b;
if(a>b) a*=2;
else if(a<b) b/=2;
std::cout<<"a = "<<a<<"\nb = "<<b;
return 0;}
Вот программа на языке Python, которая решает данную задачу:
```python a = int(input("Введите число a: ")) b = int(input("Введите число b: "))
if a > b: a *= 2 else: b -= 2
print("a =", a) print("b =", b) ```
Как работает программа: 1. Пользователю предлагается ввести число `a`. 2. Пользователю предлагается ввести число `b`. 3. Если `a` больше `b`, то значение `a` увеличивается в 2 раза. 4. Если `a` не больше `b`, то значение `b` уменьшается на 2. 5. Выводятся значения `a` и `b`.
Пример работы программы: ``` Введите число a: 5 Введите число b: 3 a = 10 b = 1 ```
``` Введите число a: 2 Введите число b: 4 a = 2 b = 2 ```
``` Введите число a: 7 Введите число b: 9 a = 14 b = 9 ```
Таким образом, программа решает задачу, увеличивая `a` в 2 раза, если оно больше `b`, и уменьшая `b` на 2 в противном случае.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
