Вопрос задан 19.06.2023 в 14:45. Предмет Информатика. Спрашивает Шишов Николай.

Напишите программу получения из элементов матрицы трёх списков.Первый состоит из чисел , больших

введенного значения , второй - из элементов, меньших этого числа, третий - из элементов , равных чисел на питоне пжжжж
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Ткачёва Юля.

matrix = ...    # тут должна быть матрица

value = int(input('Введите значение: '))

a = []

b = []

c = []

for row in matrix:

   for element in row:

       if element > value:

           a.append(element)

       elif element < value:

           b.append(element)

       else:

           c.append(element)

print(a)

print(b)

print(c)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Python, которая выполняет описанную вами задачу:

```python def разделить_по_значению(матрица, значение): большие = [] меньшие = [] равные = []

for список in матрица: for элемент in список: if элемент > значение: большие.append(элемент) elif элемент < значение: меньшие.append(элемент) else: равные.append(элемент)

return большие, меньшие, равные

# Пример использования матрица = [ [5, 10, 15], [2, 8, 12], [5, 6, 10] ]

введенное_значение = int(input("Введите число для разделения: "))

результат = разделить_по_значению(матрица, введенное_значение)

print(f"Элементы больше {введенное_значение}: {результат[0]}") print(f"Элементы меньше {введенное_значение}: {результат[1]}") print(f"Элементы равные {введенное_значение}: {результат[2]}") ```

Программа определяет три списка: элементы матрицы, большие, меньшие и равные введенному значению. Затем выводит результат для каждой категории.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос